Disturbances in Zisson
Incident Report for Zisson.com
Resolved
The incident is now resolved, we're looking into further details as to the root cause. Should you experience further disturbances please do not hesitate to contact us at: Support@zisson.no
Posted Nov 23, 2023 - 10:08 CET
Investigating
We're currently seeing some disturbances in Zisson Interact, we're investigating this with the highest priority. We'll send an update asap, at the latest 10.30 CET!
Posted Nov 23, 2023 - 09:44 CET
This incident affected: Zisson Interact.