Issues with logging in and disconnects
Incident Report for Zisson.com
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 03:17 CET
Investigating
We are currently experiencing issues with logging in and agents being disconnected from Zisson Interact.
Posted Nov 14, 2023 - 03:00 CET
This incident affected: Zisson Interact.