Call dispatching / Agent queue logon issue
Incident Report for Zisson.com
Resolved
We experienced a problem during the night of the 21st of March with Call dispatching & Agent queue logon.

Issue started approximately 02.30 and was resolved at 04.17 CET.
Posted Mar 21, 2024 - 04:17 CET